Tidepool Uploader failing to upload diabetes devices

Incident Report for Tidepool

Resolved

We believe this incident to be resolved. If you are experiencing any issues, please contact us at support@tidepool.org
Posted Apr 03, 2026 - 14:25 PDT

Update

We are continuing to monitor for any further issues.
Posted Apr 03, 2026 - 12:47 PDT

Monitoring

A fix has been put in place and we are monitoring for any additional reports. Please reach out to us at support@tidepool.org if you have any issues.
Posted Apr 03, 2026 - 12:47 PDT

Identified

The team has identified the issue and is working on a resolution.
Posted Apr 03, 2026 - 12:34 PDT

Investigating

The Tidepool team is investigating reports that diabetes devices such as glucose meters, insulin pumps, and CGMs are failing to upload to Tidepool accounts.
Posted Apr 03, 2026 - 11:40 PDT
This incident affected: Tidepool Uploader (Insulin pumps, Continuous glucose monitors (CGM), Blood glucose meters, Software updates).